Mikrotik RB951G-2HnD

Настройка высокопроизводительного маршрутизатора Mikrotik RB951G-2HnD с разгоном процессора до 750МГц.

Трудно представить себе, как жили люди до появления маршрутизатора Mikrotik RB751U-2HnD, сколько времени было потрачено на ожидание перезагрузки устройств других производителей для применения настроек, сколько раз вспоминали недобрым словом зависшие красивые коробочки, а куда хотели засунуть антенны огромных размеров, беспомощно торчащих сзади роутера, когда ноутбук через стену не мог подключиться к беспроводной сети, лучше умолчим, технический ресурс все же=)

Но все когда-то заканчивается, вот и сейчас, когда многие провайдеры перешагнули планку тарифных планов в 100 мегабит, потребовалось повышение производительности старого доброго маршрутизатора, и Mikrotik тут же среагировал, выпустив достойного приемника в виде RB951G-2HnD, который не только обладает более быстрым процессором, но и переработанным радиомодулем с новыми антеннами. Кроме быстрого процессора добавили и оперативную память, теперь доступно 128 мегабит, вместо 32 в предыдущей модели. А это значит можно гибко управлять шейперами с более глубокой буферизацией — памяти теперь хватит для любой задачи.

Начнем с обзора комплекта поставки и упаковки. Она проста и лаконична, однако крепка и функциональна — не только защищает роутер RB951G во время транспортировки, но и может использоваться в быту для складирования различных сетевых комплектующих, например радиокарт.

Внутри ничего лишнего, только Mikrotik RB951G-2HnD с блоком питания.

Как и предыдущая модель, Mikrotik RB951G располагает 5-ю гигабитными сетевыми портами с возможностью подачи питания PoE через первый из них, USB портом для подключения модема или дополнительного беспроводного адаптера. Вверху индикаторы активности интерфейсов.

Разъема для подключения внешней антенны нет. RB751U и RB751G позволяли подключить внешнюю через разъем MMCX, расположенный сзади корпуса, однако в следствии конструктивного просчета, это было достаточно не удобно и не красиво. Энтузиасты полностью удаляли внутренние антенны и припаивали вместо них пигтейлы, однако приходилось устанавливать 3 штуки, ведь один канал использовал разные антенны для приема и передачи.

С нижней стороны, как и у всех устройств серии RB751U-2HnD и RB951G-2HnD расположен кружок сброса настроек и пазы для крепления на стену. С помощью плоской отвертки нужно подцепить защелки и аккуратно снять нижнюю крышку, с задней стороны она приклеена к липучке, поэтому нужно подцепить ее со стороны сетевых портов и осторожно потянуть на себя.

Нижняя часть RouterBOARD 951G 2HnD. Обратите внимание, что теперь под антенными расположен вырез в плате, что позволяет увеличить зону покрытия беспроводной сетью не только за счет повышения мощности передатчика, но и увеличения чувствительности.

Обратите внимание что верхняя левая антенна изогнута, чуть ниже мы вернем ей первоначальную форму.

Внутренности нового маршрутизатора Mikrotik RB951G-2HnD. Компоновка полностью изменилась. Беспроводной модуль уменьшен в габаритах и закрыт индивидуальными экранами для каждого канала. Появились 2 разъема для подключения внешних антенн, да и самих антенны теперь две. Новые модули памяти компактных размеров, на процессорах установлены хорошие радиаторы. Появились и не распаянные контакты для подключения тачскрина, так что не исключено в скором времени появления не нужной примочки на устройствах в пластмассовых корпусах. Если так пойдет дело, то можно ожидать выход модели Mikrotik SXT с тачскрином для удобного наведения по уровню сигнала, который можно будет контролировать визуально=).

Вид сбоку на USB разъем RB951G-2HnD. Внизу чуть правее расположены светодиодные индикаторы, которые показывают активность сетевых портов. А еще правее видно погнутую антенну.

Возвращаемся к кривой антенне. Для обеспечения нормальной работы ее естественно нужно распрямить, однако делать это надо аккуратно, что бы не загнуть ее в обратную сторону. Ведь потом придется ее выгибать снова, а это может привести к поломке или еще большему нарушению геометрии, что ухудшит качество работы.

Изгибаем ее по аналогии с нормальной. Заодно снимаем экраны с радиомодулей, что бы убедиться что там ничего интересного нет. Любители работы с паяльником могут припаять разъемы MMCX для подключения внешних антенн, либо найти редкие пигтейлы для подключения к существующим.

Теперь, пройдя ОТК, плата Mikrotik RB951 может снова отправляться в свой пластиковый корпус.

Кстати о корпусе — он состоит из двух половинок, в верхней его части расположены места для установки 4-х разъемов под внешние антенны, еще одного разъема USB большого размера, маленького micro-USB и даже консольного порта в формате RG-45. Так что корпус не так прост, как кажется, хранит много секретов, которые еще только предстоит узнать.

 

Переходим к настройке.

Как и обычно, при первом включении отменяем начальную конфигурацию, нажав на кнопку Remove Configuration. Если это окно не появилось, то в меню System->Reset Configuration делаем сброс, поставив галочку No DefaultConfiguration, после перезагрузки можно приступать к настройке. Естественно не забываем про обновление прошивки.

Новое устройство обладает 5-ю сетевыми портами и беспроводным адаптером.

Для подключения к Интернету может использоваться несколько способов, начнем с автоматического получения адреса. Для этого в меню IP->DHCP Client добавляет новую запись, где указываем интерфейс, подключенный к сети провайдера, а так же устанавливаем все галочки — получение адреса DNS сервера и адреса сервера точного времени, самая нижняя галочка позволяет устанавливать маршрут по умолчанию через данное подключение. Она используется при одновременном подключении сразу к нескольким провайдерам.

При использовании подключения через PPPoE, понадобиться зайти в раздел PPP и добавить PPPoE_Client (нужно выбрать в выпадающем меню при нажатии на +). В нем выбираем интерфейс для подключения к провайдеру и переходим на следующую вкладку.

Где указываем логин и пароль на доступ, устанавливаем галочку Use Peer DNS для получения адреса сервера DNS от провайдера. Вот и все.

Если требуется указывать IP-адрес вручную, тогда следует посетить меню IP->Address и нажав на + указать необходимые настройки. При этом так же нужно выбрать интерфейс, куда подключен кабель провайдера. Маска подсети задается через слеш, что может внести некоторую путаницу. Например /24 означает 255.255.255.0, /23 — 255.255.252.0, /30 — 255.255.255.252, /29 — 255.255.255.248. Если в настройках указана другая маска, следует найти в Google «калькулятор маски подсети», в котором введя настройки можно получить полную расшифровку.

Кроме IP-адреса нужно не забыть указать и маршрут по умолчанию. В меню IP->Routes добавляем новый маршрут, и только указываем Gateway = 10.10.10.1 или данные вашего провайдера. Check Gateway = ping можно не ставить, эта настройка включает проверку доступности шлюза пингом и обычно используется при подключении сразу к нескольким провайдером с автоматическим переключением в случае отключения одного из них.

Для превращения микротика в маленький коммутатор следует создать бридж в разделе Bridge. Нажимаем на + и сразу на Ok, настраивать здесь нечего.

Переходим на вкладку Ports и добавляем сетевые порты в бридж, для этого нажимаем на +, выбираем нужные интерфейс и бридж из списка. Требуется добавить 2-5 сетевые порты и беспроводной адаптер.

Указываем IP-адрес на бридже. Так же в разделе IP->Address добавляем адрес 192.168.0.1/24 на интерфейсbridge1.

Настраиваем и DNS сервер микротика. В меню IP->DNS вводим адрес сервера, можно указать гуглевский 8.8.8.8, а так же нужно обязательно поставить галочку Allow Remote Requests, для разрешения отвечать на запросы с других компьютеров. Если ее не поставить, то Интернет работать не будет.

Для автоматической выдачи адресов подключенным клиентам в разделе IP->DHCP Server запускаем мастер настроек, нажатием на кнопку DHCP Setup. В первом окне выбираем интерфейс, на котором он будет работать. Т.к. все порты объединены в бридж, то выбираем bridge1.

Указываем подсеть адресов для выдачи. Все данные подставляются автоматически, однако есть возможность их корректировать. При выборе интерфейса был определена подсеть, установленная на нем — 192.168.0.0/24. Изменять ее не следует.

Шлюз для клиентов так же устанавливается автоматически 192.168.0.1 — этот адрес вводили во время настройки IP-адреса на бридже.

Адреса для выдачи клиентам. По умолчанию установлен диапазон 192.168.0.2 — 192.168.0.254, адреса выдаются с конца. Если в сети у каких-то устройств адреса установлены вручную, например в диапазоне 10-50, то можно исключить их, указав 192.168.0.100 — 192.168.0.254. Если используется более сложная конфигурация сети и в ней несколько диапазонов, установленных вручную, то можно нажав на стрелку вниз, открыть еще одно поле для указания диапазона. И ввести к примеру вверху 192.168.0.100 — 192.168.0.150, а внизу 192.168.0.200 — 192.168.0.254. Тогда адреса 2-99 и 151-199 можно указывать статически на компьютерах локальной сети.

Адрес DNS сервера для выдачи — 192.168.0.1, то есть адрес микротика. Нажав на стрелку вниз можно указать и альтернативный, либо сразу выдавать альтернативный, если не требуется использовать свой DNS сервер и перенаправлять все запросы на сервер провайдера.

Время аренды адреса. По умолчанию 3 дня, можно поставить меньше, хоть 10 минут. После нажатия на кнопкуNext настройка завершена.

Для настройки НАТ требуется зайти в меню IP->Firewall на вкладку NAT и нажать на +.

Откроется окно, где нужно указать подсеть клиентов, которые могут иметь доступ в сеть, в нашем случае указываем192.168.0.0/24. То есть правило будет работать только для адресов с 192.168.0.1 до 192.168.0.254.

На вкладке Action выбираем Masquerade.

Для защиты от атак со стороны Интернета не требуется создавать фильтры в файрволе, достаточно снять все галочки в разделе IP->Services, нужно оставить только Winbox для доступа на устройство. Если лишние сервисы не отключать, то в логах будут появляться сообщения о попытках входа с не правильными учетными данными, особенно много их будет по Telnet.

Переходим к настройке беспроводного адаптера. На вкладке Security Profiles раздела Wireless открываем профиль default и указываем.

Mode: dynamic keys.

Authentication Types: WPA PSK и WPA2 PSK — поддерживаемые типы шифрования.

Unicast и Group Ciphers: tkip и aes ccm — первое программное шифрование, второе аппаратное. Если установить все галочки, то к сети смогут подключаться новые и старые устройства вне зависимости от поддерживаемого шифрования.

WPA и WPA2 Pre-Shared Key: 1234567890 — ключи шифрования. Для подключения к сети нужно будет вводить эти же цифры/буквы на беспроводных устройствах.

Открываем окно настроек беспроводного адаптера на вкладке Interfaces, где указываем:

Mode: ap bridge — режим работы в качестве точки доступа.

Band: 2GHz-B/G/N — поддерживаемые режимы, в данном случае 2ГГц B/G/N, можно выбрать и просто B/G, либо only-G, в зависимости от требуемых скоростей.

Channel Width: 20 — ширина рабочей полосы, можно выбрать либо 20, либо 20/40 HT Above или 20/40 HT Below. Другие беспроводные адаптеры ноутбуков и коммуникаторов не поддерживают. Выбор режима Above или Below нужно проводить опытным путем, если на определенной частоте один режим не работает, следует попробовать другой.

Frequency: 2412 — рабочая частота.

SSID: TEST — имя беспроводной сети, которая будет отображаться при поиске сетей в беспроводном окружении.

Wireless Protocol: 802.11 — работа в режиме стандартного вайфая, только в нем могут подключаться другие устройства, например ноутбуки. Если указать что-то другое, беспроводная сеть может быть недоступна.

На вкладке Data Rates оставляем настройки без изменений. Что бы открыть ее нужно сперва нажать кнопкуAdvanced Mode внизу справа, сейчас там написано Simple Mode.

Если требуется отключить скорости B-режимов, нужно установить переключатель в Configured и снять все галочки с режимов Supported Rates B и Basic Rates B, однако не все беспроводные устройства могут корректно работать в таком случае, проверяется опытным путем. Если нужно разрешить работу только в режиме N, следует снять с этой вкладке все галочки.

На вкладке Advanced устанавливаются следующие значения:

Distance: indoors — расстояние до клиентов будет минимальным.

Periodic Calibration: enabled — включение переопределения уровня шума. Особенно важно, если рядом есть много других точек доступа.

Calibration Interval: 00:00:10 — интервал времени, через которое будет определятся уровень шума.

Hw. Protection Mode: RTS CTS — включение механизма защиты от скрытого узла. Даже при использовании внутри помещений следует включать данный режим, особенно если рядом имеются и другие беспроводные сети.

На вкладке HT нужно поставить все 4 галочки вверху. После сброса там включены только 2 у канала chain0, поэтому MIMO работать не сможет. Следует поставить так же 2 галочки напротив канала chain1.

На вкладке WDS следует выбрать режим Dynamic и указать бридж из списка. Собственно для подключения обычных устройств, например ноутбуков, данный режим не нужен. Но возможно понадобится в дальнейшем, а оборудование уже будет настроено.

Если включить беспроводной адаптер, то мощности по умолчанию будут высокие, на вкладке Current Tx Power это видно, 26dBm по каждому каналу, или 29dBm суммарно. Это очень много и мощность следует уменьшить.

Для уменьшения следует зайти на вкладку Tx Power и выбрать там All Rates Fixed, а чуть ниже 18dBm.

Смотрим на изменение мощностей — все стоят на уровне 18dBm или 21dBm суммарно. При таком уровне мощности оборудование сможет работать на максимальных скоростях при близко расположенных клиентских устройствах, например в пределах одной комнаты.

Если провайдер предоставляет белый IP-адрес, можно включить автоматический проброс портов в меню IP->UPnP. Устанавливаем галочку Enabled и добавляем интерфейс Bridge1 в качестве внутреннего, а Ether1 и PPPoE-Out1 в качестве внешнего.

Для ограничения доступа к настройкам в меню System->Users указываем пароль на доступ, зайдя в свойства существующего пользователя Admin.

Теперь самое интересное. Для сохранения конфигурации в текстовом виде нужно зайти в окно New Terminal и ввести там команду Export Compact.

После нажатия Enter в окно будет выведена вся конфигурация устройства в текстовом виде, если нажать в фон правой кнопкой мышки и выбрать Copy All, можно скопировать данные в буфер обмена, которые потом следует вставить в текстовый редактор, например блокнот:

/interface bridge

add name=bridge1

/interface wireless

set 0 band=2ghz-b/g/n disabled=no distance=indoors ht-rxchains=0,1 ht-txchains=\

0,1 hw-protection-mode=rts-cts l2mtu=2290 mode=ap-bridge \

periodic-calibration=enabled periodic-calibration-interval=10 radio-name=»» \

ssid=TEST tx-power=18 tx-power-mode=all-rates-fixed wds-default-bridge=\

bridge1 wds-mode=dynamic wireless-protocol=802.11

/interface pppoe-client

add add-default-route=yes disabled=no interface=ether1 name=pppoe-out1 \

password=test use-peer-dns=yes user=test

/interface wireless nstreme

set wlan1 enable-polling=no

/interface wireless security-profiles

set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods=\

passthrough group-ciphers=tkip,aes-ccm mode=dynamic-keys unicast-ciphers=\

tkip,aes-ccm wpa-pre-shared-key=1234567890 wpa2-pre-shared-key=1234567890

/ip pool

add name=dhcp_pool1 ranges=192.168.0.2-192.168.0.254

/ip dhcp-server

add address-pool=dhcp_pool1 disabled=no interface=bridge1 name=dhcp1

/interface bridge port

add bridge=bridge1 interface=ether2

add bridge=bridge1 interface=ether3

add bridge=bridge1 interface=ether4

add bridge=bridge1 interface=ether5

add bridge=bridge1 interface=wlan1

/ip address

add address=10.10.10.10/24 interface=ether1

add address=192.168.0.1/24 interface=bridge1

/ip dhcp-client

add default-route-distance=0 disabled=no interface=ether1

/ip dhcp-server network

add address=192.168.0.0/24 dns-server=192.168.0.1 gateway=192.168.0.1

/ip dns

set allow-remote-requests=yes servers=8.8.8.8

/ip firewall nat

add action=masquerade chain=srcnat src-address=192.168.0.0/24

/ip route

add check-gateway=ping distance=1 gateway=10.10.10.1

/ip service

set telnet disabled=yes

set ftp disabled=yes

set www disabled=yes

set ssh disabled=yes

/ip upnp interfaces

add interface=bridge1 type=internal

add interface=ether1 type=external

add interface=pppoe-out1 type=external

/user set 0 password=test

 

Последнюю строчку с паролем следует добавить самостоятельно, при сохранении конфигурации в текстовом виде он не сохраняется. В конфиге видны все настройки IP-адресов, их можно легко поменять и загрузить конфигурацию обратно, так же вставив в окно New Terminal.

В текстовом виде очень удобно хранить и вставлять конфигурацию, вот так, например, можно сделать DMZ с помощью Mikrotik на адрес 192.168.0.254, кроме порта винбокса:

 

/ip firewall nat

add action=netmap chain=dstnat dst-port=1-8290 in-interface=ether1 protocol=tcp to-addresses=192.168.0.254 to-ports=1-8290

add action=netmap chain=dstnat dst-port=8292-65535 in-interface=ether1 protocol=tcp to-addresses=192.168.0.254 to-ports=8292-65535

add action=netmap chain=dstnat dst-port=8292-65535 in-interface=ether1 protocol=udp to-addresses=192.168.0.254 to-ports=8292-65535

add action=netmap chain=dstnat dst-port=1-8290 in-interface=ether1 protocol=udp to-addresses=192.168.0.254 to-ports=1-8290

 

Достаточно вставить конфиг, как изменения можно просмотреть через WinBox. Перезагрузка не требуется.

Если зайти в раздел System->Resources можно увидеть что объем оперативной памяти 128 мегабайт, частота процессора 600 МГц.

Процессор можно разогнать, нажав на кнопку Settings, выбираем из списка 750MHz.

Перезагружаемся и смотрим — частота 750МГц.

Тест пропускной способности на себя показал, что Mikrotik RB951G-2HnD выдает почти 800 мегабит в секунду.

Аналогичный показатель у Mikrotik RB751U-2HnD лежит на уровне 565 мегабит в секунду, намного ниже. Но и частота процессора у него всего 450 МГц.

 

Благодаря более быстрому процессору, новому радиомодулю и грамотному размещению антенн (конечно если они не гнутые), Mikrotik RB951G-2HnD вполне достойно справится с пропуском больших объемов трафика через подключение к Интернету, а так же обеспечит уверенную зону покрытия в пределах не большой квартиры или частного дома. Компьютеры локальной сети смогут обмениваться данными на скорости 1 гигабит в секунду, что позволит экономить много времени во время переноса больших объемов информации, например вместо 2-х часов понадобится всего около 30 минут.

Источник lanmart.ru